• WELCOME Grumblers
    Backup is now done at 3PM EDT. You may find the server down for up to two minutes at that time.

Minigraf 44 leaking plug issue

Steve

Grumbler in Training
Hi guys!
I have a Alfamachine Minigraf 44 and one of the blue plugs underneath constantly leaks when the machine is hooked up to air.
When I press the foot pedal down to clamp the face of the frames it stops leaking. Once I take my foot off air rushes out.
I am using a brick to keep the pedal down so it doesn’t constantly keep my air compressor running.
It’s the second from the bottom left that is giving me the issue.
I have swapped plugs and it still happens.
Does anyone know what this is or how to fix it?
Thanks guys
 

Attachments

Sponsor Wanted

neilframer

PFG, Picture Framing God
Hi guys!
I have a Alfamachine Minigraf 44 and one of the blue plugs underneath constantly leaks when the machine is hooked up to air.
When I press the foot pedal down to clamp the face of the frames it stops leaking. Once I take my foot off air rushes out.
I am using a brick to keep the pedal down so it doesn’t constantly keep my air compressor running.
It’s the second from the bottom left that is giving me the issue.
I have swapped plugs and it still happens.
Does anyone know what this is or how to fix it?
Thanks guys
Here is something that might help.

Those blue parts are mufflers.
Most probably the valve block that the muffler is screwed into has a stuck or leaky valve and the valve block may have to be replaced due to a stuck valve.

Have you been putting a few drops of pneumatic oil into the air inlet about once a week?
You might try this and it could free up a stuck valve.

I have worked on many of the Alfa, Mitre Mite and now Fletcher v-nailers with the help of tech support and I'm a machine nerd...:cool:
Fletcher is now the company that supports the machines.
Phil was great tech support person and I'm not sure that he is still there but you might try to contact him.
Screen Shot 2017-10-22 at 12.26.58 PM.png
 

Steve

Grumbler in Training
Thanks for the advice. I bought the machine about a year ago but had it in storage due to us moving house and setting up a new shop.
I’ve had it up and running for about a week and haven’t put any oil in it.
I’ll give that a try and let you know how I go.
Cheers:beer:
 
Sponsor Wanted
Top